通达信VR_CCI主升浪副图指标公式(附源码)

你的位置:实盘炒股杠杆开户_股票杠杆配资操作_炒股杠杆配资申请 > 股票杠杆配资操作 > 通达信VR_CCI主升浪副图指标公式(附源码)
通达信VR_CCI主升浪副图指标公式(附源码)
发布日期:2023-09-26 20:39    点击次数:99

程序源码

N:=26;

M:=6;

TH:=SUM(IF(CLOSE>REF(CLOSE,1),vol,0),N);

TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),N);

TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);

VR:100*(TH*2+TQ)/(TL*2+TQ);

MAvr:MA(VR,M);

DRAWBAND(VR,RGB(255,0,0),MAVR,RGB(0,255,0));

CC1:cci(25),COLORSTICK,COLOR40FF00;

DRAWICON(crOSS(200,CCI),250,2);

DRAWICON( CROSS(CCI,-200),-250,1);

转强:CCI>0,COLOR0000D5,NODRAW;

{STICKLINE(CCI>0,0,CCI,2,0),COLOR0000D5;}

弱转强:CROSS(CCI,-200) AND CCI>REF(CCI,1),COLOR00DFDF,NODRAW;

STICKLINE(CROSS(CCI,-200) AND CCI>REF(CCI,1),CCI,0,2,0),COLOR00DFDF;

强转弱:CROSS(200,CCI) AND CCI<REF(CCI,1),COLOR00CA00,NODRAW;

STICKLINE(CROSS(200,CCI) AND CCI<REF(CCI,1),0,CCI,2,0),COLOR00CA00;

生命CCI线:CCI(84),COLORWHITE;

底部线:-100.00,COLORYELLOW,LINETHICK2;

警戒线:300.00,COLORWHITE,LINETHICK2;

生命线:80.00,COLORRED,LINETHICK2;

轴:0.00,COLORLIBLUE ,LINETHICK2;

DRAWTEXT(CROSS(生命CCI线,底部线),底部线,'主升浪')COLORYELLOW;

DRAWTEXT(CROSS(生命CCI线,警戒线),警戒线,'警惕')COLORYELLOW;

DRAWTEXT(CROSS(生命CCI线,生命线),生命线,'强')COLORYELLOW;

DRAWTEXT(CROSS(生命CCI线,轴),轴,'注')COLORYELLOW;

注:


       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。


       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。